Исправление базы данных

Материал из Info

(Перенаправлено с Восстановление базы данных)
Перейти к: навигация, поиск

В исключительно редких случаях возможно появление проблемы в базе данных. Для ее исправления предвидены соответствующие процедуры, которые зависят от вида базы.

Содержание

Подготовка к изменению базы

Прежде, чем начать реальное изменение базы данных, необходимо выполнить ряд процедур по проверке системы. Процедуры включают следующие шаги:

  • Проверка свободного места на диске. Необходимо обратить внимание на папки, которые сохраняют базу данных, сам раздел с Windows и временные папки;
  • Ошибки MSDE , Microsoft SQL Server 2005/2008/2012/2014/2016 записываются в Event Log Windows (Start/Control panel/Administrative Tools/Event Viewer), откуда можно понять, где именно проблема: в диске, в базе данных или в самом SQL сервере;
  • Осуществляется проверка папок на наличие поврежденных секторов на диске;
  • Осуществляется проверка последней архивной копии базы данных, при условии, что обнаружено наличие архива, в котором установлено повреждение, и он не проходит проверку на целостность. Простейшим решением проблемы является восстановление базы данных из архива.

После выполнения этих обязательных действий можно приступить к фактическому ремонту базы данных.

Access

При исправлении базы данных Access необходимо выполнить следующие действия:

  1. Обязательно создается архивная копия базы данных. Используются следующие методы:
    • Если есть возможность открыть базу данных при помощи самой программы, то резервная копия базы создается в меню Файл / Резервное копирование и восстановление. Имя и путь к базе данных проверяется в меню Файл / Активная база данных;
    • Если возникают проблемы с открытием базы данных при помощи программы, то осуществляется ее копирование вручную в другую, нерабочую папку. Папка базы данных описана в этой статье: Папка с продуктами.
  2. Открывается база данных в MS Access, версии 2003, 2007 или 2010. Для получения доступа к базе данных необходимо ввести инженерный пароль, который можно получить в отделе технической поддержки в Болгарии (Предоставляется только партнёрам Микринвест);
  3. Если при открытии базы данных Microsoft Access появляется сообщение, что файл не может быть использован, то возникает необходимость подключения дополнительного программного обеспечения для восстановления данных или поиска заархивированной копии базы данных;
  4. После открытия БД, в зависимости от версии MS Access, выбирается:
    • MS Access 2003 - из меню Tools->Database Utilities->Compact and Repair Database...;
    • MS Access 2007 - выбирается кнопка Office Button, которая находится в верхнем левом углу, потом опция Manage и Compact and Repair Database;
    • MS Access 2010 - из меню File->Info->Compact & Repair;

Таким образом, изменение базы данных завершено.

MySQL

Для того чтобы произвести изменение базы данных сервера MySQL, необходимо наличие дополнительных инструментов:

После установки MySQL GUI Tools или MySQL Administrator, следует запустить MySQL Administrator, который запрашивает дополнительную информацию для соединения с сервером, содержащим базу данных.
Поля, необходимые для подключения к серверу:
Server Host - название или IP сервера, на котором находится база данных. Данные этого поля соответствуют аналогичным данным в настройке Microinvest Склад Pro;
Username - Имя пользователя для подключения к серверу. По умолчанию это root. Данные поля соответствуют аналогичным данным в настройке Microinvest Склад Pro;
Pasword - Пароль для подключения к серверу. Данные поля соответствуют аналогичным данным в настройке Microinvest Склад Pro.

После успешного запуска MySQL Administrator и осуществления подключения к базе данных, выполняются следующие шаги:

  1. Создаем архив базы данных:
    1. Используется Microinvest Архи Pro
    2. "MySQL Administrator" - содержит встроенные функции для создания архивов, выполняются следующие операции:
      • В верхнем левом меню выбирается Backup;
      • В нижнем правом углу нажимается кнопка New Project;
      • Левой кнопкой мыши выделяется база данных, которую хотите заархивировать (Schema);
      • Нажимается маленькая квадратная кнопка ">" для того, чтобы подтвердить выбор указанной базы данных. Она будет отражена в правой части приложения вместе с относящимися к ней таблицами (Backup Content);
      • Подтверждение происходит нажатием кнопки Execute Backup Now;
      • Открывается окошко Save As, в котором нужно указать, где будет сохранен архивный файл;
      • После выбора кнопки Save начинается процесс создания архива. Необходимо дождаться появления системного сообщения "The Backup was finished successfully". Операция по созданию архива заканчивается нажатием OK;
  2. В верхнем левом меню выбирается Catalogs. В нижнем левом меню появляются базы данных, которые расположены на данном сервере;
  3. Выбирается база данных и выделяется левой кнопкой мыши. В правой части программы появляется структура баз данных и относящиеся к ней таблицы (Schema Tables);
  4. В нижнем правом углу расположена кнопка Maintenance. Открываются опции задач, и там указывается Repair Tables. Подтверждается с "Next >>", выделяется уровень изменения Extended. Последним шагом является активация "Repair Tables".

На этом процесс изменения БД MySQL завершен.

MSDE и Microsoft SQL Server 2000

Для выполнения изменения базы данных необходимо наличие инструментов для управления самим сервером:

  1. Процедуры осуществляются с помощью Microsoft SQL Server Management Studio;
    • При условии, что версия Windows является 64-битной, скачать 64-битную версию можно по следующей ссылке: Microsoft SQL Server Management Studio;
    • Если на компьютере не установлен MSXML6.0, то этот компонент необходимо инсталлировать до начала установки Microsoft SQL Server Management Studio;
    • MSXML6.0 для 64-битной версии Windows доступен здесь;
  2. После успешной установки компонентов, запускается Microsoft SQL Server Management Studio и подключается к серверу MSDE путем указания имени и пароля пользователя для доступа к SQL серверу. Эти параметры настраиваются еще при установке MSDE и соответствуют параметрам для соединения с базой данных в программе;
  3. В Microsoft SQL Server Management Studio раскрывается папка Databases, выделяется база, которую необходимо восстановить, и при помощи правой кнопки мыши выбирается опция „New Query”. Аналогичный результат можно получить путем выделения левой кнопкой мыши базы данных, выбирая команду „New Query”;
  4. В открывшемся окне выписываются следующие команды:
ALTER DATABASE   db_name  SET SINGLE_USER WITH ROLLBACK IMMEDIATE;
DBCC CHECKDB (  'db_name'  , REPAIR_ALLOW_DATA_LOSS);
ALTER DATABASE   db_name  SET MULTI_USER;

где вместо db_name записывается имя базы, нуждающейся в восстановлении. Все заявки выполняются в окне путем нажатия клавиши F5 или кнопки Execute в Microsoft SQL Server Management Studio. В зависимости от величины базы данных и вида ошибок, время обработки заявки может варьировать от нескольких секунд до нескольких часов.

  1. Когда завершается обработка заявок, в Microsoft SQL Server Management Studio выводится информация по базе данных. Если в разделе Messages присутствуют строчки, выделенные красным цветом, это означает, что заявка обнаружила проблемы в БД. В большинстве случаев обнаруженные проблемы обработаны, и, соответственно, в разделе Messages следует описание о том, удалось ли устранить обнаруженные ошибки или нет.
  2. В том случае, если не удается установить, исправлена ли база данных, можно заново запустить заявки для проверки. При повторном запуске заявок не должно быть строк, выделенных красным цветом.

Microsoft SQL Server 2005+

Для выполнения исправления базы данных необходимо наличие инструментов для управления самим сервером:

  1. Процедуры осуществляются с помощью Microsoft SQL Server Management Studio 2005 или Microsoft SQL Server Management Studio 2008;
    • При условии, что версия Windows является 64-битной, скачать 64-битную версию можно по ссылке: Microsoft SQL Server Management Studio 2005 или Microsoft SQL Server Management Studio 2008;
    • Если на компьютере не установлен MSXML6.0, то этот компонент необходимо инсталлировать до начала установки Microsoft SQL Server Management Studio;
    • MSXML6.0 для 64-битной версии Windows доступен здесь;
  2. После успешной установки компонентов, запускается Microsoft SQL Server Management Studio и подключается к SQL Server. Имя пользователя и пароль соответствуют заданным при установке сервера и совпадают с логином и паролем программы;
  3. Раскрывается папка Databases, выделяется база, которую необходимо восстановить, и правой кнопкой мыши выбирается опция „New Query”. Аналогично базу данных можно выделить левой кнопкой мыши и выбрать „New Query”;
  4. В окне справа выводятся следующие команды:
ALTER DATABASE   db_name  SET SINGLE_USER WITH ROLLBACK IMMEDIATE;
DBCC CHECKDB (  'db_name'  , REPAIR_ALLOW_DATA_LOSS);
ALTER DATABASE   db_name  SET MULTI_USER;

где вместо db_name записывается имя базы, нуждающейся в исправлении. Все заявки выполняются в окне путем нажатия клавиши F5 или кнопки Execute в Microsoft SQL Server Management Studio. В зависимости от величины базы данных и вида ошибок, время обработки заявки может варьировать от нескольких секунд до нескольких часов;

  1. Когда завершается обработка заявок, в Microsoft SQL Server Management Studio выводится информация по базе данных. Если в разделе Messages присутствуют строчки, выделенные красным цветом, это означает, что заявка обнаружила и исправила ошибки в базе данных. В большинстве случаев эти проблемы устранены. В разделе Messages описано исправлены ли обнаруженные ошибки или нет;
  2. В том случае, если не удается установить, изменена ли база данных успешно, можно заново запустить заявки для проверки. При повторном запуске заявок не должно быть строк, выделенных красным цветом.

База в режиме Suspected

Иногда сам сервер сообщает, что определенная база является "сомнительной". В таком случае она отмечается как "Suspected", и появляется необходимость выполнения ряда команд.

Для Microsoft SQL Server 2005/2008/2008 R2/2012/2014/2016:

sp_resetstatus 'db_name';
ALTER DATABASE  db_name   SET EMERGENCY;
DBCC CHECKDB ( 'db_name' ) ;
ALTER DATABASE  db_name   SET SINGLE_USER WITH ROLLBACK IMMEDIATE;
DBCC CHECKDB ( 'db_name' , REPAIR_ALLOW_DATA_LOSS);
ALTER DATABASE  db_name  SET MULTI_USER;

где вместо db_name пишется имя базы данных. В случае обнаружения ошибки, в разделе Messages будут присутствовать строчки, выделенные красным цветом. Необходимо выполнить все строки запроса. Строку DBCC CHECKDB ( 'db_name' , REPAIR_ALLOW_DATA_LOSS), возможно, придется выполнить несколько раз, до устранения всех ошибок.
Заявки необходимо обрабатывать последовательно, строчка за строчкой, а не все вместе.

Для MSDE и Microsoft SQL Server 2000 выполняются:

USE master;
sp_resetstatus  'db_name' ;
sp_configure 'allow updates',1;
reconfigure with override;
UPDATE sysdatabases SET status = 32768 WHERE name = 'db_name' ;
DBCC CHECKDB (  'db_name' ) ;
ALTER DATABASE   db_name  SET SINGLE_USER WITH ROLLBACK IMMEDIATE;
DBCC CHECKDB (  'db_name'  , REPAIR_ALLOW_DATA_LOSS);
ALTER DATABASE   db_name  SET MULTI_USER;
UPDATE sysdatabases SET status = 4194328 WHERE name = 'db_name';
sp_configure 'allow updates',0;
reconfigure with override;

где вместо db_name пишется имя поврежденной базы данных. При наличии проблем, в разделе Messages вновь будут присутствовать строчки, выделенные красным цветом.
Заявки необходимо обрабатывать последовательно, строчка за строчкой, а не все вместе;

Некоторые полезные ресурсы


Рассмотрите другие статьи в категории Решение проблем | Анализ